木果资源分享博客-分享个人精选资源,本博客没有固定的主题,什么都会分享,如果您喜欢请按Ctrl+D收藏本博客,木果为您分享更多你喜欢的资源。

热门搜索

败类 gta5 媒体创作 Admin/login 外挂 \\think\\app/invokefunction api/\\think\\app/invokefunction user/\\think\\app/invokefunction
登录成功

账号登录

还没有账号? 去注册 >

忘记密码

注册

已有账号 去登录 >

邮箱注册

已有账号 去登录 >

广告
腾讯云产品低至1折起
当前位置: 首页 / 其他资源 / 【免费】网络验证API接口分享-卡密/在线升级

【免费】网络验证API接口分享-卡密/在线升级

简介

2018k网络验证,木果本人在这个网络验证的群里也有多年,后来也混成了管理员,自己做的一些保持更新的程序也是用的这个网络验证,以前没事还跟作者交换友链啥的,现在作者不搞友链了,我顺便分享一下他的API例子。

不要问我安不安全稳不稳定这些话,问就是不安全,也不要问我服务器好不好,能免费给你用就已经是烧高香了,觉得不靠谱自己去换收费的,不要在评论区给我瞎喷,喷我都不会给你审核评论。

2018k网络验证

后台地址:admin.2018k.cn

开发者交流群:458427251(提示:太阳级以下小号、Q龄在1年以下的小号、广告协议号、网络骗子、学了点技术觉得自己很了不起的勿扰!)

注册如果提示需要邀请码,请进群自取,相关链接我就不放这里了,自己去群公告看。

【免费】网络验证API接口分享-卡密/在线升级

易语言模块下载

蓝奏云下载

官网有开源的模块源码,有兴趣可以自行去官网下载出来捣鼓,这里我就只分享一个E模块。

例子

名称URL
获取实例信息/v2/getSoftwareInfo
获取卡密信息/v2/getAuthInfo
获取机器授权/v2/getMachineAuth
卡密创建/v2/createAuth
卡密解绑/v2/unBind

获取实例信息 /v2/getSoftwareInfo

通过实例ID查询实例基本信息

● URL: /v2/getSoftwareInfo
● Method:GET

请求参数

http://api.2018k.cn/v2/getSoftwareInfo?softwareId=8821A498FFE545A998A6AEE6D14A572B

1. softwareId: <实例ID>
{
    "code": 0,
    "success": true,
    "message": "请求成功",
    "data": {
        "lowVersion": null, // 最低版本
        "softwareId": "8821A498FFE545A998A6AEE6D14A572B",
        "force": false, // 强制更新
        "remark": "remark", // 更新内容
        "url": "", // 下载地址
        "notice": "notice", // 公告信息
        "visit": 0, // 访问量
        "md5": "",
        "name": "软件A",
        "version": "1.0" // 版本号
    }
}

获取卡密信息 /v2/getAuthInfo

根据卡密编号查询卡密基本信息

● URL: /v2/getAuthInfo
● Method:GET

请求参数

http://api.2018k.cn/v2/getAuthInfo?authId=BDF52743FDC04387AE152C5D9D10680F

1. authId: <卡密编号>
{
    "code": 0,
    "success": true,
    "message": "请求成功",
    "data": {
        "authId": "BDF52743FDC04387AE152C5D9D10680F",
        "createDat": "2024-03-15 11:53:18", // 创建时间
        "softwareId": "8821A498FFE545A998A6AEE6D14A572B", // 实例ID
        "machineCode": "BFEBFBFF-000A0653-00000000-00000000--120_2F.3", // 机器码
        "status": true, // 是否激活
        "day": 0, // 卡密天数,0表示永久
        "validity": "2080-12-06 00:00:00" // 到期时间
    }
}

获取机器授权 /v2/getMachineAuth

根据当前机器码和实例ID查询当前机器的注册信息,未注册时 success 返回false

● URL: /v2/getMachineAuth
● Method:GET

请求参数

http://api.2018k.cn/v2/getMachineAuth?authId=BDF52743FDC04387AE152C5D9D10680F

1. machineCode: <机器码>
2. softwareId: <实例ID>
{
    "code": 0,
    "success": true,
    "message": "请求成功",
    "data": {
        "authId": "BDF52743FDC04387AE152C5D9D10680F",
        "createDat": "2024-03-15 11:53:18", // 创建时间
        "softwareId": "8821A498FFE545A998A6AEE6D14A572B", // 实例ID
        "machineCode": "BFEBFBFF-000A0653-00000000-00000000--120_2F.3", // 机器码
        "status": true, // 是否激活
        "day": 0, // 卡密天数,0表示永久
        "validity": "2080-12-06 00:00:00" // 到期时间
    }
}

创建卡密 /v2/createAuth

通过API创建一个卡密,敏感API,需要通过加密方式传递,通过 CryptoJS.ec 模块 AES.AES_encrypt
* 可参考模块源码

● URL: /v2/createAuth
● Method:GET

请求参数

http://api.2018k.cn/v2/createAuth?softwareId=8821A498FFE545A998A6AEE6D14A572B&info=U2FsdGVkX19kSaHYkxtMQbxiIPaBXbqSNuQdYdCLDdbJcO1P9Kw5f8XEpy10j79PjTknnBjSMJB1pbGcg2Zs/LpF/veF7d35DXakNpxgH2bGmtVxZ1D/QBjuZRjxIS5yUM5ZErgAaGnwlGhfhjXLGw==

1. info: <加密内容> , 加密内容如下:
    {
        "id": "8821A498FFE545A998A6AEE6D14A572B", // 实例ID
        "day": 7, // 卡密天数
        "remark": "test", // 卡密备注
        "times": "1710489748" // 当前时间戳
    }
2. softwareId: <实例ID>

注意:info 字段通过 AES.AES_encrypt 加密info json内容后,加密密匙为你的openId 
{
    "code": 0,
    "success": true,
    "message": "请求成功",
    "data": "8329A47047DA48F5820DC9EF8E480C4F" // 卡密编号
}

卡密解绑 /v2/unBind

通过API创建一个卡密,敏感API,需要通过加密方式传递,通过 CryptoJS.ec 模块 AES.AES_encrypt
* 可参考模块源码

● URL: /v2/unBind
● Method:GET

请求参数

http://api.2018k.cn/v2/unBind?softwareId=8821A498FFE545A998A6AEE6D14A572B&info=U2FsdGVkX19BCoKb0qNP5nD0icL6Ak7lvRei9Lu+iPkkS48+0fi+1BV50+Cef6aI0YnvgwRuswa7mpYG17PSVZvmoFdRjCeFGJmY4kspV8jxAZ+YBnGNWrKcSrLVEfSg

1. info: <加密内容> , 加密内容如下:
    {
        "macid": "BFEBFBFF-000A0653-00000000-00000000--120_2F.3", // 机器码
        "times": "1710490334" // 时间戳
    }
2. softwareId: <实例ID>

注意:info 字段通过 AES.AES_encrypt 加密info json内容后,加密密匙为你的openId 
{
    "code": 0,
    "success": true,
    "message": "请求成功",
    "data": "2024-03-15 16:12:14"
}
【免费】网络验证API接口分享-卡密/在线升级

易语言例子

.版本 2

.子程序 检查最新版本
.局部变量 检测版本是否最新, 我的软件
.局部变量 下载链接, 我的软件
.局部变量 更新内容, 我的软件

检测版本是否最新.连接 (“实例ID”, “程序版本号”)
下载链接.连接 (“实例ID”, “程序版本号”)
更新内容.连接 (“实例ID”, “程序版本号”)
标签1.标题 = “V” + 到文本 (检测版本是否最新.取版本号 ())
编辑框1.内容 = 到文本 (下载链接.取下载地址 ())
' 超文本浏览框1.跳转 (到文本 (更新内容.取更新内容 ()), , )
编辑框2.内容 = 到文本 (更新内容.取更新内容 ())
超级链接框1.Internet地址 = 编辑框1.内容


.子程序 _按钮1_被单击


检查最新版本 () ' 该按钮为点击后检查版本是否有更新


.子程序 _按钮2_被单击


超级链接框1.跳转 () ' 该按钮为点击后为跳转下载最新程序,自己可以用http模块改一个在线更新。

【免费】网络验证API接口分享-卡密/在线升级

以上截图为木果自己写的某个程序里的代码例子,仅供参考。

模块公开信息

【免费】网络验证API接口分享-卡密/在线升级

创建卡密

参数类型备注
AccountToken文本型后台个人资料-点击【开发钥匙】获取。
OpenID文本型AccountToken, 后台个人资料-点击【开发钥匙】获取。
卡密有效期天数整数型卡密有效期天数,参考范围:1 ~ 20000, 0:永久
卡密备注文本型可空, 卡密备注

连接(网络验证)

参数类型备注
软件编号文本型软件ID,你需要验证的软件ID,可在后台复制
机器码文本型可空, 用户电脑唯一编号,请确保机器码唯一 可空,不传默认使用模块规则生成的编号

剩余时间

参数类型备注
返回类型整数型可空, 1. 剩余秒数, 2 返回天数,3 返回过期时间 默认返回剩余秒数

返回剩余秒数,如果返回 -1 表示为永久

注册本机

参数类型备注
注册码文本型

传入AuthID进行注册

2018k果子(木果)提供参考

    打赏
    点赞
    收藏

    上一篇Vmware虚拟机v13.4版本下载-小白必备工具

    下一篇【日结】BT手游CPS推广项目-60%充值抽成-详情